<!DOCTYPE html>
<html lang="en-US">
<head>

<meta charset="utf-8"><script type="text/javascript">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</script><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://bookriot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://bookriot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://bookriot.com/feed/atom/" />
<link rel="pingback" href="https://bookriot.com/xmlrpc.php" />

<title>10 Fascinating Books Like The Flight Attendant | Book Riot</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://s2982.pcdn.co/wp-content/cache/min/1/81ca555db429f0278259b3a21fd47aef.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
<meta name="description" content="If you’re looking for another mystery to have to you turning pages, these are the best books like The Flight Attendant to put on your TBR." />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://bookriot.com/books-like-the-flight-attendant/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="10 Fascinating Books Like The Flight Attendant | Book Riot" />
<meta property="og:description" content="If you’re looking for another mystery to have to you turning pages, these are the best books like The Flight Attendant to put on your TBR." />
<meta property="og:url" content="https://bookriot.com/books-like-the-flight-attendant/" />
<meta property="og:site_name" content="BOOK RIOT" />
<meta property="article:publisher" content="https://www.facebook.com/BookRiot/" />
<meta property="article:published_time" content="2021-03-29T10:33:00+00:00" />
<meta property="article:modified_time" content="2021-03-26T19:06:12+00:00" />
<meta property="og:image" content="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="373" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@https://twitter.com/sarahrahman711" />
<meta name="twitter:site" content="@bookriot" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Sarah Rahman">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="4 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://bookriot.com/#website","url":"https://bookriot.com/","name":"BOOK RIOT","description":"Book Recommendations and Reviews","potentialAction":[{"@type":"SearchAction","target":"https://bookriot.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://bookriot.com/books-like-the-flight-attendant/#primaryimage","inLanguage":"en-US","url":"https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg","width":700,"height":373,"caption":"the flight attendant film still"},{"@type":"WebPage","@id":"https://bookriot.com/books-like-the-flight-attendant/#webpage","url":"https://bookriot.com/books-like-the-flight-attendant/","name":"10 Fascinating Books Like The Flight Attendant | Book Riot","isPartOf":{"@id":"https://bookriot.com/#website"},"primaryImageOfPage":{"@id":"https://bookriot.com/books-like-the-flight-attendant/#primaryimage"},"datePublished":"2021-03-29T10:33:00+00:00","dateModified":"2021-03-26T19:06:12+00:00","author":{"@id":"https://bookriot.com/#/schema/person/173a28cdbfa2e2c39f506b818c6e4f77"},"description":"If you’re looking for another mystery to have to you turning pages, these are the best books like The Flight Attendant to put on your TBR.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://bookriot.com/books-like-the-flight-attendant/"]}]},{"@type":"Person","@id":"https://bookriot.com/#/schema/person/173a28cdbfa2e2c39f506b818c6e4f77","name":"Sarah Rahman","description":"As a recent college graduate who studied English just so she could read more books, Sarah spends most of her time devouring whatever catches her fancy, from classics to young adult reads. She aspires to write a novel someday. When not reading or talking about books, she can be found hiking in the woods or dancing alone in her room. Now, for that cup of tea she was making . . .","sameAs":["https://twitter.com/https://twitter.com/sarahrahman711"]}]}</script>

<link rel="amphtml" href="https://bookriot.com/books-like-the-flight-attendant/amp/" /><meta name="generator" content="AMP for WP 1.0.76.8"/><link rel='dns-prefetch' href='//cdn.taboola.com' />
<link rel='dns-prefetch' href='//www.youtube.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s2982.pcdn.co' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="BOOK RIOT &raquo; Feed" href="https://bookriot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="BOOK RIOT &raquo; Comments Feed" href="https://bookriot.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='preload'   href='https://fonts.googleapis.com/css?family=PT+Serif&#038;display=swap&#038;ver=5.4.3' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/sticky-sidebar.js?ver=march16_2"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/ads/ls.unveilhooks.min.js?ver=5.4.3"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/vendor/jquery.min.js?ver=1.12.4-wp"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/nectar-nav.js?ver=march16_2"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var newsletter_form={"ajaxurl":"https:\/\/bookriot.com\/wp-content\/themes\/bookriot\/lib\/sailthru-ajax-jsonp.php"};</script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/newsletter-form.js?ver=march16_2"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/ohayou/resize-sensor.js?ver=march16_2"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/post.js?ver=march16_2"></script>
<script data-phast-original-type="text/javascript" type="text/phast" data-rocketlazyloadscript="https://cdn.taboola.com/libtrc/riotnewmedia-network/loader.js?ver=march16_2"></script>
<link rel='https://api.w.org/' href='https://bookriot.com/wp-json/' />
<meta name="generator" content="WordPress 5.4.3" />
<link rel='shortlink' href='https://bit.ly/31fkPNZ' />
<link rel="alternate" type="application/json+oembed" href="https://bookriot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbookriot.com%2Fbooks-like-the-flight-attendant%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://bookriot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbookriot.com%2Fbooks-like-the-flight-attendant%2F&#038;format=xml" />
<script data-phast-no-defer>console.log("%cOptimized with %cPhastPress%c %s\nhttps:\/\/wordpress.org\/plugins\/phastpress\/","font-family:helvetica,sans-serif","font-family:helvetica,sans-serif;font-weight:bold","font-family:helvetica,sans-serif","1.114")</script> <script data-phast-original-type="text/javascript" type="text/phast">dataLayer=[];dataLayer.push({'authorName':'Sarah Rahman'});dataLayer.push({'categoryName':'Lists,Mystery/Thriller,Pop Culture'});</script>

<meta name="sailthru.date" content="2021-03-29 06:33:00" />
<meta name="sailthru.title" content="10 Fascinating Books Like THE FLIGHT ATTENDANT" />
<meta name="sailthru.tags" content="psychological thrillers, the flight attendant, site-bookriot, post-type-post, lists, mystery-thriller, pop-culture" />
<meta name="sailthru.author" content="Sarah Rahman" />
<meta name="sailthru.description" content="&lt;p&gt;If you’re looking for another mystery to have to you turning pages, these are the best books like &lt;em&gt;The Flight Attendant&lt;/em&gt; to put on your TBR, including &lt;a class=&quot;butter&quot; title=&quot;Buy From Amazon&quot; href=&quot;http://www.amazon.com/gp/product/1501132954/ref=as_li_tf_il?ie=UTF8&amp;tag=rnmgnewslette-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1501132954&quot; target=&quot;_blank&quot; rel=&quot;nofollow noopener&quot; data-title=&quot;The Woman in Cabin 10&quot; data-publisher=&quot;Gallery/Scout Press&quot; data-releasedate=&quot;2017-04-11&quot;&gt;The Woman in Cabin 10&lt;/a&gt; by Ruth Ware.&lt;/p&gt;
" />
<meta name="sailthru.image.full" content="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg" />
<meta name="sailthru.image.thumb" content="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1-50x27.jpg.optimal.jpg" />

<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_32.png" sizes="32x32">
<link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_128.png" sizes="128x128">
<link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_152.png" sizes="152x152">
<link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_167.png" sizes="167x167">
<link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_180.png" sizes="180x180">
<link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_192.png" sizes="192x192">
<link rel="icon" href="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/favicons/BookRiot_Logo_196.png" sizes="196x196">
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="text/phast">(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script>
<script type="text/phast" data-rocketlazyloadscript="data:text/javascript;base64,KGZ1bmN0aW9uKHcsZCxzLGwsaSl7d1tsXT13W2xdfHxbXTt3W2xdLnB1c2goeydndG0uc3RhcnQnOg0KbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5qcyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLA0Kaj1kLmNyZWF0ZUVsZW1lbnQocyksZGw9bCE9J2RhdGFMYXllcic/JyZsPScrbDonJztqLmFzeW5jPXRydWU7ai5zcmM9DQonaHR0cHM6Ly93d3cuZ29vZ2xldGFnbWFuYWdlci5jb20vZ3RtLmpzP2lkPScraStkbDtmLnBhcmVudE5vZGUuaW5zZXJ0QmVmb3JlKGosZik7DQp9KSh3aW5kb3csZG9jdW1lbnQsJ3NjcmlwdCcsJ2RhdGFMYXllcicsJ0dUTS1OM1hUNlhCJyk7"></script>

<meta property="fb:pages" content="119200448178678" />
<script type="text/phast">if(typeof(__gaTracker)!=='undefined')
window.ga=__gaTracker;</script>

<script data-phast-original-type="text/javascript" type="text/phast" data-rocketlazyloadscript="data:text/javascript;base64,DQoJCXZhciBfcWV2ZW50cyA9IF9xZXZlbnRzIHx8IFtdOw0KDQoJCShmdW5jdGlvbigpIHsNCgkJdmFyIGVsZW0gPSBkb2N1bWVudC5jcmVhdGVFbGVtZW50KCdzY3JpcHQnKTsNCgkJZWxlbS5zcmMgPSAoZG9jdW1lbnQubG9jYXRpb24ucHJvdG9jb2wgPT0gImh0dHBzOiIgPyAiaHR0cHM6Ly9zZWN1cmUiIDogImh0dHA6Ly9lZGdlIikgKyAiLnF1YW50c2VydmUuY29tL3F1YW50LmpzIjsNCgkJZWxlbS5hc3luYyA9IHRydWU7DQoJCWVsZW0udHlwZSA9ICJ0ZXh0L2phdmFzY3JpcHQiOw0KCQl2YXIgc2NwdCA9IGRvY3VtZW50LmdldEVsZW1lbnRzQnlUYWdOYW1lKCdzY3JpcHQnKVswXTsNCgkJc2NwdC5wYXJlbnROb2RlLmluc2VydEJlZm9yZShlbGVtLCBzY3B0KTsNCgkJfSkoKTsNCgk="></script>
<script type="text/phast" async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script type="text/phast">window.googletag=window.googletag||{cmd:[]};googletag.cmd.push(function(){googletag.defineSlot('/207207792/BookRiot_1600x520_ATF_PG1',['fluid',[300,250],[970,66],[300,100],[970,90],[970,250],[1600,520]],'top_takeover_responsive').addService(googletag.pubads());googletag.defineSlot('/207207792/BookRiot_1600x520_ArticleDiv_PG2',[[970,90],[1600,520],[970,66],[300,100],[300,600],[300,250],[970,250],'fluid'],'middle').addService(googletag.pubads());googletag.defineSlot('/207207792/BookRiot_300x600_ATF_PG1',[[300,250],[160,600],[240,400],[300,600]],'sidebar').addService(googletag.pubads());googletag.defineSlot('/207207792/BookRiot_300x250_InContent_PG1',[[300,250],[300,100],[240,400],[300,600],'fluid'],'inside1').addService(googletag.pubads());googletag.defineSlot('/207207792/BookRiot_300x250_InContent2_PG1',[[300,100],[240,400],[300,600],[300,250],'fluid'],'inside2').addService(googletag.pubads());googletag.pubads().enableLazyLoad({fetchMarginPercent:500,renderMarginPercent:200,mobileScaling:2.0});googletag.pubads().enableSingleRequest();googletag.enableServices();googletag.display('top_takeover_responsive');});</script></head>
<body class="post-template-default single single-post postid-463121 single-format-standard br lists mystery-thriller pop-culture loading date20210329" data-categories="lists mystery-thriller pop-culture ">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N3XT6XB"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<nav class="over">
<div class="navigation-close-button menu-nav-button"></div>
<div class="over-container">
<section class="over-media">
<div class="over-read">
<h3 class="section-title"><a href="/read">Articles</a></h3>
<ul>
<li><a href="/read"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/BR_logo_navmenu.png"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/BR_logo_navmenu.png"></noscript> <span>Main</span></a></li>
<li><a href="/category/audiobooks"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-audiobooks.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-audiobooks.svg"></noscript> <span>Audiobooks</span></a></li><li><a href="/category/childrens"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-childrens.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-childrens.svg"></noscript> <span>Children's</span></a></li><li><a href="/category/comics-graphic-novels"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-comics-graphic-novels.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-comics-graphic-novels.svg"></noscript> <span>Comics</span></a></li><li><a href="/category/mystery-thriller"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-mystery-thriller.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-mystery-thriller.svg"></noscript> <span>Mystery/Thriller</span></a></li><li><a href="/category/nonfiction"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-nonfiction.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-nonfiction.svg"></noscript> <span>Nonfiction</span></a></li><li><a href="/category/romance"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-romance.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-romance.svg"></noscript> <span>Romance</span></a></li><li><a href="/category/science-fiction-fantasy"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-science-fiction-fantasy.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-science-fiction-fantasy.svg"></noscript> <span>Sci-Fi/Fantasy</span></a></li><li><a href="/category/young-adult-literature"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-young-adult-literature.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-young-adult-literature.svg"></noscript> <span>Young Adult</span></a></li> <li><a href="/category/read-harder"><img class="icon" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-read-harder.svg"><noscript><img class="icon" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/svgs/genre-read-harder.svg"></noscript> <span>Read Harder</span></a></li>
</ul>
</div>
<div class="over-listen">
<h3 class="section-title"><a href="/listen">Listen</a></h3>
<ul>
<li><a href="https://bookriot.com/listen/shows/allthebooks/"><div class="thumbnail allthebooks"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_allTheBooks_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_allTheBooks_3000x3000.png' width='50' height='50'></noscript></div><span>All The Books</span></a></li>
<li><a href="https://bookriot.com/listen/shows/thepodcast/"><div class="thumbnail thepodcast"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_thePodcast_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_thePodcast_3000x3000.png' width='50' height='50'></noscript></div><span>Book Riot: The Podcast</span></a></li>
<li><a href="https://bookriot.com/listen/shows/forreal/"><div class="thumbnail forreal"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_forReal_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_forReal_3000x3000.png' width='50' height='50'></noscript></div><span>For Real</span></a></li>
<li><a href="https://bookriot.com/listen/shows/getbooked/"><div class="thumbnail getbooked"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_getBooked_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_getBooked_3000x3000.png' width='50' height='50'></noscript></div><span>Get Booked</span></a></li>
<li><a href="https://bookriot.com/listen/shows/heyya/"><div class="thumbnail heyya"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_heyYA_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_heyYA_3000x3000.png' width='50' height='50'></noscript></div><span>Hey YA</span></a></li>
<li><a href="https://bookriot.com/listen/shows/kidlit-these-days/"><div class="thumbnail kidlit-these-days"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_kidlitTheseDays_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_kidlitTheseDays_3000x3000.png' width='50' height='50'></noscript></div><span>Kidlit These Days</span></a></li>
<li><a href="https://bookriot.com/listen/shows/readordead/"><div class="thumbnail readordead"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_readOrDead_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_readOrDead_3000x3000.png' width='50' height='50'></noscript></div><span>Read or Dead</span></a></li>
<li><a href="https://bookriot.com/listen/shows/sffyeah/"><div class="thumbnail sffyeah"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_sffYeah_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_sffYeah_3000x3000.png' width='50' height='50'></noscript></div><span>SFF Yeah!</span></a></li>
<li><a href="https://bookriot.com/listen/shows/when-in-romance/"><div class="thumbnail when-in-romance"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2050%2050'%3E%3C/svg%3E" width='50' height='50' data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_whenInRomance_3000x3000.png"><noscript><img src='https://s2982.pcdn.co/wp-content/uploads/2020/03/BR_whenInRomance_3000x3000.png' width='50' height='50'></noscript></div><span>When In Romance</span></a></li>
</ul>
</div>
<span></span>
</section>
<section class="over-other">
<ul id="menu-submenuctas" class="cta-links"><li id="menu-item-297653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297653"><a href="https://bookriot.com/newsletters/">Newsletters Galore</a></li>
<li id="menu-item-297654" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297654"><a href="https://bookriot.com/category/book-fetish/">Buy Some Bookish Goods</a></li>
<li id="menu-item-297655" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297655"><a target="_blank" rel="noopener noreferrer" href="https://insiders.bookriot.com/">Join Insiders</a></li>
<li id="menu-item-297656" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297656"><a href="https://bookriot.com/giveaways/">Enter a Giveaway</a></li>
<li id="menu-item-297657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297657"><a href="https://bookriot.com/category/deals/">Save on Books</a></li>
<li id="menu-item-297658" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297658"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/user/BookRiotVideo/">Watch Bookish Content</a></li>
</ul>
<ul id="menu-mainnavsubitems" class="subnav-links"><li id="menu-item-91707" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91707"><a href="https://bookriot.com/about/">About Book Riot</a></li>
<li id="menu-item-91709" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91709"><a href="https://bookriot.com/advertise/">Advertise</a></li>
<li id="menu-item-428383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428383"><a href="https://bookriot.com/join-us/">Join Us</a></li>
<li id="menu-item-91710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91710"><a href="https://bookriot.com/contact/">Contact</a></li>
<li id="menu-item-91711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91711"><a href="https://bookriot.com/staff-contributors/">Staff &#038; Contributors</a></li>
<li id="menu-item-94486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94486"><a href="https://bookriot.com/about/community-guidelines/">Community Guidelines</a></li>
</ul> <ul class="over-social">
<li><a class="fa icon-facebook" target="_blank" href="http://facebook.com/bookriot" title="Follow Book Riot on Facebook"></a></li>
<li><a class="fa icon-twitter" target="_blank" href="http://twitter.com/bookriot" title="Follow Book Riot on Twitter"></a></li>
<li><a class="fa icon-pinterest" target="_blank" href="https://www.pinterest.com/bookriot/" title="Follow Book Riot on Pinterest"></a></li>
<li><a class="fa icon-youtube" target="_blank" href="https://www.youtube.com/user/BookRiotVideo" title="Follow Book Riot on Youtube"></a></li>
<li><a class="fa icon-instagram" target="_blank" href="http://instagram.com/bookriot" title="Follow Book Riot on Instagram"></a></li>
</ul>
</section>
</div>
</nav>
<nav class="main-nav relative">
<div class="button-and-logo absolute abs-left">
<div class="menu-nav-button nav-corner-box nav-corner-left">
<div class="tooltip-content">Menu</div>
<span class="bar bar1"></span>
<span class="bar bar2"></span>
<span class="bar bar3"></span>
</div>
<div class="logo">
<a itemprop="url" href="https://bookriot.com/">
<img alt="Book Riot Logo" src="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/BR_logo_192x192.png" data-skip-lazyload />
</a>
</div>
<div class="mobile-share">
<a class="trackable" data-category="Social Share" data-value="Masthead Facebook" onclick="window.open('http://www.facebook.com/sharer.php?u=https://bookriot.com/books-like-the-flight-attendant/&amp;t=10 Fascinating Books Like THE FLIGHT ATTENDANT', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<div class="share-button facebook"><i class="fa icon-facebook fa-2"></i></div>
</a>
<a class="trackable" data-category="Social Share" data-value="Masthead Twitter" onclick="window.open('http://twitter.com/share?text=10+Fascinating+Books+Like+THE+FLIGHT+ATTENDANT -&amp;url=https://bookriot.com/books-like-the-flight-attendant/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<div class="share-button twitter"><i class="fa icon-twitter fa-2"></i></div>
</a>
<a class="trackable" data-category="Social Share" data-value="Masthead Pinterest" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://bookriot.com/books-like-the-flight-attendant/&amp;media=&amp;description=10 Fascinating Books Like THE FLIGHT ATTENDANT', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<div class="share-button pinterest"><i class="fa icon-pinterest fa-2"></i></div>
</a>
<a class="trackable" data-category="Social Share" data-value="Masthead Email Share" href="mailto:?subject=&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://bookriot.com/books-like-the-flight-attendant/">
<div class="share-button email"><i class="fa icon-envelope fa-2"></i></div>
</a>
</div>
</div>
<div class="nav-content-right">
<div class="search-button nav-corner-box nav-corner-right">
<svg x="0px" y="0px" viewBox="0 0 32 32">
<path class="st0" d="M29.1,24.7l-8.6-8.6c2.2-4.1,1.6-9.4-1.9-12.9c-4.3-4.3-11.2-4.3-15.4,0c-4.3,4.3-4.3,11.2,0,15.4
		c3.5,3.5,8.8,4.1,12.9,1.9l8.6,8.6c1.2,1.2,3.2,1.2,4.4,0C30.3,27.9,30.3,25.9,29.1,24.7z M5.1,16.7c-3.2-3.2-3.2-8.4,0-11.6
		c3.2-3.2,8.4-3.2,11.6,0c3.2,3.2,3.2,8.4,0,11.6C13.5,19.9,8.3,19.9,5.1,16.7z"></path>
</svg>
</div>
<a class="store-button" href="https://bookriot.com/category/book-fetish/?utm_source=br-homepage&utm_medium=site-button&utm_campaign=tbr-top-nav-button">Shop</a>
</div>
<div id="search-bar">
<div class="whiteout-bar"></div>
<div class="container">
<form role="search" method="get" id="searchform" class="searchform" action="https://bookriot.com/" >
<div class="controls">
<input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form> </div>
<div class="navigation-close-button search-close-button"></div>
</div>
<nav class="genre-nav">
<ul><li><a href="/category/audiobooks">Audiobooks</a></li><li><a href="/category/childrens">Children's</a></li><li><a href="/category/comics-graphic-novels">Comics</a></li><li><a href="/category/mystery-thriller">Mystery/Thriller</a></li><li><a href="/category/nonfiction">Nonfiction</a></li><li><a href="/category/romance">Romance</a></li><li><a href="/category/science-fiction-fantasy">Sci-Fi/Fantasy</a></li><li><a href="/category/young-adult-literature">Young Adult</a></li></nav>
</nav>
<div id="top_takeover" style="display:block !important;">
<div id="top_takeover_responsive"></div>
<div id="top-alt-content random_content_pro_widget-5" class="alt-content widget_random_content_pro_widget"><div class="random-content-pro-wrapper" data-id="461920" data-campaign-name="$250 BN AC March 21" data-vars-campaign-name="$250 BN AC March 21"><a target="_blank" class="fullwidth" href="https://bookriot.com/giveaways/win-250-to-spend-at-barnes-and-noble-march-2021"><img class="alignnone size-full wp-image-166706" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20970%20250'%3E%3C/svg%3E" alt="" width="970" height="250" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_9.jpg.optimal.jpg" /><noscript><img class="alignnone size-full wp-image-166706" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_9.jpg.optimal.jpg" alt="" width="970" height="250" /></noscript></a>
<a target="_blank" class="mobile" href="https://bookriot.com/giveaways/win-250-to-spend-at-barnes-and-noble-march-2021"><img class="mobile" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="" width="300" height="250" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_3.jpg.optimal.jpg" /><noscript><img class="mobile" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_3.jpg.optimal.jpg" alt="" width="300" height="250" /></noscript></a>
<a target="_blank" class="sidebar" href="https://bookriot.com/giveaways/win-250-to-spend-at-barnes-and-noble-march-2021"><img class="sidebar" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20600'%3E%3C/svg%3E" alt="" width="300" height="600" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_6.jpg.optimal.jpg" /><noscript><img class="sidebar" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_6.jpg.optimal.jpg" alt="" width="300" height="600" /></noscript></a></div></div> </div>
<div class="riot-headline container" data-post-id="461659">
<a href="https://bookriot.com/how-to-help-texas-recovery/">
<span class="riot-headline-title">Riot Headline</span>
<span class="headline-text">Literary Activism: How To Help Texas&#8217;s Recovery</span>
</a>
</div>
<div id="post-main-wrap" class="left relative" itemscope itemtype="http://schema.org/Article">
<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg">
<meta itemprop="width" content="700">
<meta itemprop="height" content="373">
</div>
<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://s2982.pcdn.co/wp-content/themes/bookriot/assets/images/BR_textlogo2.png">
<meta itemprop="width" content="427">
<meta itemprop="height" content="94">
</div>
<meta itemprop="name" content="Book Riot">
</div>
<div id="post-area">
<div class="social-wrap-outer">
<div class="social-share-stack-fixed">
<div class="post-social-share">
<a class="trackable share-button" rel="noreferrer" data-category="Social Share" data-value="Sharebar Facebook" onclick="window.open('http://www.facebook.com/sharer.php?u=https://bookriot.com/books-like-the-flight-attendant/&amp;t=10 Fascinating Books Like THE FLIGHT ATTENDANT', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<i class="icon-facebook"></i>
</a>
<a class="trackable share-button" rel="noreferrer" data-category="Social Share" data-value="Sharebar Twitter" onclick="window.open('http://twitter.com/share?text=10+Fascinating+Books+Like+THE+FLIGHT+ATTENDANT-&amp;url=https://bookriot.com/books-like-the-flight-attendant/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<i class="icon-twitter"></i>
</a>
<a class="trackable share-button" rel="noreferrer" data-category="Social Share" data-value="Sharebar Pinterest" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://bookriot.com/books-like-the-flight-attendant/&amp;media=https://bookriot.com/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg&amp;description=10 Fascinating Books Like THE FLIGHT ATTENDANT', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<i class="icon-pinterest-circled"></i>
</a>
<a class="trackable share-button" rel="noreferrer" data-category="Social Share" data-value="Sharebar Email" href="mailto:?subject=10 Fascinating Books Like THE FLIGHT ATTENDANT&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://bookriot.com/books-like-the-flight-attendant/">
<i class="icon-envelope"></i>
</a>
</div>
</div>
</div>
<article class="container post-463121 post type-post status-publish format-standard has-post-thumbnail hentry category-lists category-mystery-thriller category-pop-culture tag-psychological-thrillers tag-the-flight-attendant">
<div class="post-content" itemprop="mainEntityOfPage">
<div class="featured-image">
<img data-pin-url="https://bookriot.com/books-like-the-flight-attendant/" width="620" height="330" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20620%20330'%3E%3C/svg%3E" class="attachment-large size-large wp-post-image" alt="the flight attendant film still" data-lazy-srcset="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg 700w, https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1-300x160.jpg.optimal.jpg 300w, https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1-50x27.jpg.optimal.jpg 50w" data-lazy-sizes="(max-width: 620px) 100vw, 620px" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg" /><noscript><img data-pin-url="https://bookriot.com/books-like-the-flight-attendant/" width="620" height="330" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg" class="attachment-large size-large wp-post-image" alt="the flight attendant film still" srcset="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1.jpg.optimal.jpg 700w, https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1-300x160.jpg.optimal.jpg 300w, https://s2982.pcdn.co/wp-content/uploads/2021/03/the-flight-attendant-film-still-feature-700x375-1-50x27.jpg.optimal.jpg 50w" sizes="(max-width: 620px) 100vw, 620px" /></noscript> </div>
<header class="post-header">
<h1 class="post-title" itemprop="name headline">
10 Fascinating Books Like THE FLIGHT ATTENDANT
</h1>
<div class="post-info left relative">
<span class="author-name vcard fn" itemprop="author"><a href="https://bookriot.com/author/sarah-rahman/" title="Posts by Sarah Rahman" rel="author">Sarah Rahman</a></span>
<time class="post-date updated" itemprop="datePublished" datetime="2021-03-29">Mar 29, 2021</time>
<meta itemprop="dateModified" content="2021-03-29" />
</div>
</header>
<div class="affiliate-disclosure">This post contains affiliate links. When you buy through these links, Book Riot may earn a commission.</div>
<div class="content-area" itemprop="articleBody" class="post-463121 post type-post status-publish format-standard has-post-thumbnail hentry category-lists category-mystery-thriller category-pop-culture tag-psychological-thrillers tag-the-flight-attendant">
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p>HBO Max&rsquo;s TV adaptation of <a title="Buy from Amazon" rel="noopener noreferrer" product-id="052543268X" href="http://www.amazon.com/gp/product/052543268X/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=052543268X" target="_blank" butter="butter" nofollow="nofollow" data-title="The Flight Attendant: A Novel (Vintage Contemporaries)" data-publisher="Vintage" data-releasedate="2019-01-08" class="butter">The Flight Attendant</a> by Chris Bohjalian has got everyone in the mood for a good psychological thriller. The story follows flight attendant Cassandra Bowen who wakes up hungover one morning, only to find that the man she spent the night with is dead, with no memory of how he was killed. A character-driven story that plays with memory and keeps you guessing, it&rsquo;s no wonder that the book had me hooked. If you&rsquo;re looking for another mystery to have to you turning pages, these are the best books like <em>The Flight Attendant</em> to put on your TBR. </p>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/0062060562/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0062060562" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/before-i-go-to-sleep-cover-e1615730716509.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/before-i-go-to-sleep-cover-e1615730716509.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="0062060562" href="http://www.amazon.com/gp/product/0062060562/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0062060562" target="_blank" butter="butter" nofollow="nofollow" data-title="Before I Go to Sleep: A Novel" data-publisher="Harper Paperbacks" data-releasedate="2012-02-07" class="butter">Before I Go to Sleep</a> by S.J. Watson</h3><div class="bookblurb__description"><p>The heroine of this novel suffers from memory loss. Christine wakes up every morning without any idea of who she is. With the help of her husband, Ben, she pieces together bits of her life, remembering an accident that changed her life. However, as Christine slowly puts the truth together, she realizes that not everything is as it seems.</p><p>As in <em>The Flight Attendant</em>, this book also features a mystery where memory loss plays a role, and it&rsquo;s interesting to watch the story unfold in layers.</p></div></div></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/1594634025/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1594634025" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/girl-on-the-train-cover-e1615730756834.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/girl-on-the-train-cover-e1615730756834.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="1594634025" href="http://www.amazon.com/gp/product/1594634025/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1594634025" target="_blank" butter="butter" nofollow="nofollow" data-title="The Girl on the Train" data-publisher="Riverhead Books" data-releasedate="2016-07-12" class="butter">The Girl on the Train</a> by Paula Hawkins</h3><div class="bookblurb__description"><p>Hawkins&rsquo;s novel centers around three women &mdash; Rachel, a recent divorcee who drowns her sorrows in alcohol, Anna, the new wife of Rachel&rsquo;s ex-husband, and Megan, a young married woman who works as a nanny for Anna&rsquo;s child. Then Megan goes missing, and the thread connecting these three lives pulls taut, bringing everyone together and unraveling secrets.</p><p>A woman-centered novel that deals with themes of alcoholism, this a good mystery to complement <em>The Flight Attendant.</em></p></div></div></div>
<div id="inside1" class="inside-content-ad-container"><script type="text/phast">googletag.cmd.push(function(){googletag.display(inside1);});</script></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/1501132954/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1501132954" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/woman-in-cabin-10-cover-e1615730797724.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/woman-in-cabin-10-cover-e1615730797724.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="1501132954" href="http://www.amazon.com/gp/product/1501132954/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1501132954" target="_blank" butter="butter" nofollow="nofollow" data-title="The Woman in Cabin 10" data-publisher="Gallery/Scout Press" data-releasedate="2017-04-11" class="butter">The Woman in Cabin 10</a> by Ruth Ware</h3><div class="bookblurb__description"><p>Complementary to <em>The Girl on the Train</em>, Ware&rsquo;s book follows travel writer Lo on a luxury cruise. Dosed on anxiety medication and alcohol, Lo sees a woman being thrown overboard. The mystery arises when Lo tries to report what she saw, only to be told that all passengers are aboard and accounted for.</p></div></div></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/B00BU493BC/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=B00BU493BC" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-red-queen-dies-cover-e1615730915717.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-red-queen-dies-cover-e1615730915717.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="B00BU493BC" href="http://www.amazon.com/gp/product/B00BU493BC/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=B00BU493BC" target="_blank" butter="butter" nofollow="nofollow" data-title="The Red Queen Dies: A Mystery (Detective Hannah McCabe Book 1)" data-publisher="Minotaur Books" data-releasedate="2013-09-10" class="butter">The Red Queen Dies</a> by Frankie Y. Bailey</h3><div class="bookblurb__description"><p>In this futuristic sci-fi mystery, a drug called Lullaby is used to treat soldiers for post-traumatic stress disorder. The pill erases traumatic memories, freeing the user from the painful burden. When two women are murdered in quick succession and one of the witnesses has taken the pill, it becomes more difficult for Detective Hannah McCabe to catch what looks more and more to be a serial killer.</p></div></div></div>
<style>.container .newsletter-signup { background: linear-gradient(to bottom, #b70401, #Ffd5d5 95%)}</style><div class="newsletter-signup">
<div class="newsletter-wrap">
<div class="newsletter-heading">
<div class="newsletter-name">Unusual Suspects Newsletter</div>
<div class="newsletter-description">Sign up to Unusual Suspects to receive news and recommendations for mystery/thriller readers.</div>
</div>
<form class="newsletter-form">
<div class="inputs">
<input class="newsletter-firstname" type="text" name="firstname" id="firstname">
<input class="newsletter-email" type="email" name="email" placeholder="Email">
<input class="newsletter-validate" type="submit" value="Let's Do This">
</div>
<input type="hidden" name="sailthru_email_list" value="BookRiot_Master">
<input type="hidden" name="newsletter" value="BookRiot_UnusualSuspects">
<input type="hidden" name="action" value="add_subscriber">
<input type="hidden" name="template" value="BookRiot_DoubleOptIn">
</form>
<div class="newsletter-error"></div>
<div class="newsletter-confirmation">Thank you for signing up! Keep an eye on your inbox.</div>
<small class="newsletter-terms">By signing up you agree to our <a target="_blank" href="https://riotnewmedia.com/legal/terms-of-use/">terms of use</a></small>
</div>
</div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/0143113496/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0143113496" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/in-the-woods-cover-e1615730840145.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/in-the-woods-cover-e1615730840145.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="0143113496" href="http://www.amazon.com/gp/product/0143113496/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0143113496" target="_blank" butter="butter" nofollow="nofollow" data-title="In the Woods: A Novel" data-publisher="Penguin Books" data-releasedate="2008-05-27" class="butter">In the Woods</a> by Tana French</h3><div class="bookblurb__description"><p>As a child, Detective Rob Ryan was one of three children who went missing, and the only one who had been found. His memories from that time are missing &mdash; he doesn&rsquo;t remember what happened to him or the other children, his blood-filled sneakers the only chilling clue. When he comes upon a case where a 12-year-old girl is murdered, it looked eerily like what happened to him years earlier, and Ryan must dig through his fragmented memories to solve the mystery.</p></div></div></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/0062225448/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0062225448" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/reconstructing-amelia-cover.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/reconstructing-amelia-cover.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="0062225448" href="http://www.amazon.com/gp/product/0062225448/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0062225448" target="_blank" butter="butter" nofollow="nofollow" data-title="Reconstructing Amelia: A Novel" data-publisher="Harper Perennial" data-releasedate="2013-12-03" class="butter">Reconstructing Amelia</a> by Kimberly McCreight</h3><div class="bookblurb__description"><p>When Kate receives a distressing call about her daughter, she rushes to Amelia&rsquo;s private school, Grace Hall, only to find the scene flooded by authorities. She&rsquo;s told that under pressure after caught cheating on a test, overachiever Amelia jumped to her death. It is the story that Kate believes as well, until a mysterious text tells her that Amelia didn&rsquo;t jump. Kate then goes on to seek out what happened to her daughter, reconstructing a secret past.</p></div></div></div>
<div id="inside2" class="inside-content-ad-container"><script type="text/phast">googletag.cmd.push(function(){googletag.display(inside2);});</script></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/B06XYPNLZS/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=B06XYPNLZS" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/dead-meat-cover-e1615730945547.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/dead-meat-cover-e1615730945547.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="B06XYPNLZS" href="http://www.amazon.com/gp/product/B06XYPNLZS/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=B06XYPNLZS" target="_blank" butter="butter" nofollow="nofollow" data-title="Dead Meat: There's a Butcher on the Loose" data-publisher="Penguin" data-releasedate="2015-02-06" class="butter">Dead Meat</a> by Ankush Saikia</h3><div class="bookblurb__description"><p>Saikia&rsquo;s novel features private detective Arjun Arora, who takes on a missing person case only to unearth a dead body. Set in urban India, Arora follows clues that all point to larger powers at play. Of course, his job would be much easier if he wasn&rsquo;t bogged down by a bad marriage and questionable drinking habits&hellip;</p></div></div></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/1501162780/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1501162780" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-elizas-cover-e1615730966522.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-elizas-cover-e1615730966522.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="1501162780" href="http://www.amazon.com/gp/product/1501162780/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=1501162780" target="_blank" butter="butter" nofollow="nofollow" data-title="The Elizas: A Novel" data-publisher="Atria Books" data-releasedate="2019-01-15" class="butter">The Elizas</a> by Sara Shepard</h3><div class="bookblurb__description"><p>Debut writer Eliza Fontaine barely escapes death when she finds herself at the bottom of a hotel pool. Her family is convinced it was another suicide attempt, but Eliza knows she&rsquo;s been pushed. As Eliza tries to find her attacker, she finds that the events in her life and her novel are not as separate as she might have hoped.</p></div></div></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><a href="http://www.amazon.com/gp/product/0375724400/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0375724400" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/when-we-were-orphans-cover-e1615730987622.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/when-we-were-orphans-cover-e1615730987622.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript></a><h3 class="bookblurb__booktitle"><a title="Buy from Amazon" rel="noopener noreferrer" product-id="0375724400" href="http://www.amazon.com/gp/product/0375724400/ref=as_li_tf_il?ie=UTF8&amp;tag=boorio-20&amp;linkCode=as2&amp;camp=217145&amp;creative=399349&amp;creativeASIN=0375724400" target="_blank" butter="butter" nofollow="nofollow" data-title="When We Were Orphans: A Novel" data-publisher="Vintage" data-releasedate="2001-10-30" class="butter">When We Were Orphans</a> by Kazuo Ishiguro</h3><div class="bookblurb__description"><p>At first glance, <em>When We Were Orphans </em>seems a far cry from <em>The Flight Attendant</em>. More a mystery than a thriller, Ishiguro&rsquo;s novel tells the story of detective Christopher Banks, whose parents vanish under strange circumstances. The story jumps back and forth in time as Banks remembers his early days as an English boy growing up in Japan and his present investigation into his parents&rsquo; disappearance. Like <em>The Flight Attendan</em>t, this book examines memory, and has an intriguing exploration of the human psyche, and the stories we tell ourselves.</p></div></div></div>
<div class="wp-block-book-blurb-block-main bookblurb-block"><div class="card__content"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" aria-hidden="true" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-woman-in-the-window-cover-e1615730816441.jpg.optimal.jpg"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" class="bookblurb__image" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/the-woman-in-the-window-cover-e1615730816441.jpg.optimal.jpg" alt="" aria-hidden="true"></noscript><h3 class="bookblurb__booktitle"><em>The Woman in the Window</em> by A. J. Finn</h3><div class="bookblurb__description"><p>Anna Fox is a recluse. She spends her time drinking wine and spying on her neighbors. Then the Russells, a seemingly perfect family, move in next door and Anna witnesses something shocking while spying on them. Anna is thrown for a loop as she tries to uncover how much of what she watched was real, and how much imagined.</p><p>While this book played less with twists and turns, it was nonetheless a gripping page-turner.</p></div></div></div>
<hr class="wp-block-separator">
<p>All of these books like <em>The Flight Attendant</em> are in some way or another connected to themes in the book, be it through missing or questionable memory, possible conspiracies at play, or a gripping storyline. Find more <a rel="noreferrer noopener" href="https://bookriot.com/psychological-thrillers-for-fall-2020" target="_blank">psychological thrillers here</a>!</p>
<p>And if you want more made-for-you recommendations, sign up for <a href="https://mytbr.co/?utm_source=bookriot&amp;utm_medium=referral&amp;utm_campaign=SEO-posts" target="_blank">Tailored Book Recommendations</a> for more books that hit the mark! </p>
<figure class="wp-block-image size-large"><a href="https://mytbr.co/?utm_source=bookriot&amp;utm_medium=referral&amp;utm_campaign=SEO-posts" target="_blank"><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" class="wp-image-438944" data-lazy-srcset="https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601.png 800w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-300x98.png 300w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-768x250.png 768w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-700x228.png 700w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-50x16.png 50w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601.png"><noscript><img data-pin-title="10 Fascinating Books Like THE FLIGHT ATTENDANT" src="https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601.png" alt="" class="wp-image-438944" srcset="https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601.png 800w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-300x98.png 300w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-768x250.png 768w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-700x228.png 700w, https://s2982.pcdn.co/wp-content/uploads/2020/07/TBR_forthebirds_800x2601-50x16.png 50w" sizes="(max-width: 800px) 100vw, 800px"></noscript></a></figure>
<script type="text/phast">"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel="stylesheet" href="https://s2982.pcdn.co/wp-content/cache/min/1/81ca555db429f0278259b3a21fd47aef.css" media="all" data-minify="1" /><link rel='stylesheet' id='ohayou-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif&#038;display=swap&#038;ver=5.4.3' type='text/css' media='all' /></noscript></body></html>
</div>
</div>
<div class="sidebar-container left">

<div class="sidebar-outer" id="sidebar-lock">
<div class="sidebar-inner" id="sidebar-inner">
<div class="sidebar widget_nectar_ad"><div id='sidebar' class='sidebar-ad-container' data-post='463121'>
<script type="text/phast">googletag.cmd.push(function(){googletag.display('sidebar');});</script>
</div></div><div class="sidebar widget_random_content_pro_widget"><div class="random-content-pro-wrapper" data-id="461920" data-campaign-name="$250 BN AC March 21" data-vars-campaign-name="$250 BN AC March 21"><a target="_blank" class="fullwidth" href="https://bookriot.com/giveaways/win-250-to-spend-at-barnes-and-noble-march-2021"><img class="alignnone size-full wp-image-166706" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20970%20250'%3E%3C/svg%3E" alt="" width="970" height="250" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_9.jpg.optimal.jpg" /><noscript><img class="alignnone size-full wp-image-166706" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_9.jpg.optimal.jpg" alt="" width="970" height="250" /></noscript></a>
<a target="_blank" class="mobile" href="https://bookriot.com/giveaways/win-250-to-spend-at-barnes-and-noble-march-2021"><img class="mobile" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="" width="300" height="250" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_3.jpg.optimal.jpg" /><noscript><img class="mobile" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_3.jpg.optimal.jpg" alt="" width="300" height="250" /></noscript></a>
<a target="_blank" class="sidebar" href="https://bookriot.com/giveaways/win-250-to-spend-at-barnes-and-noble-march-2021"><img class="sidebar" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20600'%3E%3C/svg%3E" alt="" width="300" height="600" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_6.jpg.optimal.jpg" /><noscript><img class="sidebar" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/BNGC2020_6.jpg.optimal.jpg" alt="" width="300" height="600" /></noscript></a></div></div> </div>
</div>
</div>
<div class="sidebar-container right">
<div class="sidebar-outer" id="sidebar-right-lock">
<div class="sidebar-inner" id="sidebar-right-inner">
</div>
</div>
</div>
</article>
<section class="below-content container">
<div class="post-content">
<div id="random_content_pro_widget-13" class="below-single-post widget_random_content_pro_widget"><div class="random-content-pro-wrapper" data-id="463966" data-campaign-name="$100 Books of Wonder March-April RC" data-vars-campaign-name="$100 Books of Wonder March-April RC">Enter to win a <a target="_blank" href="https://bookriot.com/giveaways/win-100-to-spend-at-books-of-wonder/">$250 gift card to Barnes and Noble!</a>
<a target="_blank" href="https://bookriot.com/giveaways/win-100-to-spend-at-books-of-wonder/"><img class="aligncenter size-full wp-image-456502" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20970%20250'%3E%3C/svg%3E" alt="" width="970" height="250" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2021/03/BR_BOW_970x250.jpg.optimal.jpg" /><noscript><img class="aligncenter size-full wp-image-456502" src="https://s2982.pcdn.co/wp-content/uploads/2021/03/BR_BOW_970x250.jpg.optimal.jpg" alt="" width="970" height="250" /></noscript></a></div></div><div id="random_content_pro_widget-14" class="below-single-post widget_random_content_pro_widget"><div class="random-content-pro-wrapper" data-id="456058" data-campaign-name="Audiobooks.com RC2" data-vars-campaign-name="Audiobooks.com RC2">Start an <a target="_blank" href="https://affiliates.audiobooks.com/tracking/scripts/click.php?a_aid=5fda7b005e226&amp;a_bid=04b436f5">Audiobooks.com Free Trial</a> and listen to all your faves!
<a target="_blank" href="https://affiliates.audiobooks.com/tracking/scripts/click.php?a_aid=5fda7b005e226&amp;a_bid=04b436f5"><img class="alignnone size-full wp-image-456059" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20970%20250'%3E%3C/svg%3E" alt="" width="970" height="250" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/Audiobooks-970.png" /><noscript><img class="alignnone size-full wp-image-456059" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/Audiobooks-970.png" alt="" width="970" height="250" /></noscript></a></div></div><div id="custom_html-2" class="widget_text below-single-post widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-1"></div></div></div> </div>
<div class="sidebar-container left">
<div id="sidebar-below" class="sidebar-outer">
<div class="sidebar-inner">
<div id="random_content_pro_widget-15" class="below-single-post-left-sidebar widget_random_content_pro_widget"><div class="random-content-pro-wrapper" data-id="456062" data-campaign-name="Audiobooks.com RC3" data-vars-campaign-name="Audiobooks.com RC3"><a target="_blank" href="https://affiliates.audiobooks.com/tracking/scripts/click.php?a_aid=5fda7b005e226&amp;a_bid=04b436f5"><img class="alignnone wp-image-456060 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20600'%3E%3C/svg%3E" alt="" width="300" height="600" data-lazy-src="https://s2982.pcdn.co/wp-content/uploads/2020/12/Audiobooks-300.jpg.optimal.jpg" /><noscript><img class="alignnone wp-image-456060 size-full" src="https://s2982.pcdn.co/wp-content/uploads/2020/12/Audiobooks-300.jpg.optimal.jpg" alt="" width="300" height="600" /></noscript></a></div></div>
</div>
</div>
</div>
<div class="sidebar-container right"></div>
</section>
</div>
</div>
<footer id="footer">
<div class="container">
<a href="http://riotnewmedia.com/" target="_blank"><div class="rnmg-logo"></div></a>
<div class="social-buttons">
<a rel="noreferrer" href="http://facebook.com/bookriot" title="Follow books-like-the-flight-attendant on Facebook" target="_blank">
<span class="subscribe-button facebook"><i class="fa icon-facebook fa-2"></i></span>
</a>
<a rel="noreferrer" href="http://twitter.com/bookriot" title="Follow books-like-the-flight-attendant on Twitter" target="_blank">
<span class="subscribe-button twitter"><i class="fa icon-twitter fa-2"></i></span>
</a>
<a rel="noreferrer" href="https://www.pinterest.com/bookriot/" title="Follow books-like-the-flight-attendant on Pinterest" target="_blank">
<span class="subscribe-button pinterest"><i class="fa icon-pinterest fa-2"></i></span>
</a>
<a rel="noreferrer" href="https://www.youtube.com/user/BookRiotVideo" title="Follow books-like-the-flight-attendant on Youtube" target="_blank">
<span class="subscribe-button youtube"><i class="fa icon-youtube fa-2"></i></span>
</a>
<a rel="noreferrer" href="http://instagram.com/bookriot" title="Follow books-like-the-flight-attendant on Instagram" target="_blank">
<span class="subscribe-button instagram"><i class="fa icon-instagram fa-2"></i></span>
</a>
</div>
<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-436304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-436304"><a target="_blank" rel="noopener noreferrer" href="https://riotnewmedia.com/legal/affiliate-disclosure/">Affiliate Disclosure</a></li>
<li id="menu-item-1247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1247"><a target="_blank" rel="noopener noreferrer" href="https://bookriot.com/join-us/">Join Us</a></li>
<li id="menu-item-1249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1249"><a target="_blank" rel="noopener noreferrer" href="https://bookriot.com/advertise/">Advertise</a></li>
<li id="menu-item-1277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1277"><a target="_blank" rel="noopener noreferrer" href="https://bookriot.com/contact/">Contact</a></li>
<li id="menu-item-436305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-436305"><a target="_blank" rel="noopener noreferrer" href="https://riotnewmedia.com/legal/privacy-policy/">Privacy</a></li>
<li id="menu-item-73311" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73311"><a target="_blank" rel="noopener noreferrer" href="https://bookriot.com/sitemap/">Sitemap</a></li>
</ul></div>
<div class="copyright-wrap">
<a href="//www.dmca.com/Protection/Status.aspx?ID=79f44dc3-0f30-4502-a4a0-08dbf22bcfdd" title="DMCA.com Protection Status" class="dmca-badge" target="_blank">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="DMCA.com Protection Status" data-lazy-src="https://images.dmca.com/Badges/dmca-badge-w200-5x1-01.png?ID=79f44dc3-0f30-4502-a4a0-08dbf22bcfdd" /><noscript><img src ="https://images.dmca.com/Badges/dmca-badge-w200-5x1-01.png?ID=79f44dc3-0f30-4502-a4a0-08dbf22bcfdd" alt="DMCA.com Protection Status" /></noscript></a>
<script type="text/phast" data-rocketlazyloadscript="https://images.dmca.com/Badges/DMCABadgeHelper.min.js"></script>
<span class="copyright">© 2021 Riot New Media Group</span>
</div>
</div>
</footer>
<style>
	</style>
<script data-phast-original-type="text/javascript" type="text/phast"></script>
<script type="text/phast" data-rocketlazyloadscript="data:text/javascript;base64,KGZ1bmN0aW9uKHMsdSxtLG8saix2KXtqPXUuY3JlYXRlRWxlbWVudChtKTt2PXUuZ2V0RWxlbWVudHNCeVRhZ05hbWUobSlbMF07ai5hc3luYz0xO2ouc3JjPW87ai5kYXRhc2V0LnN1bW9TaXRlSWQ9JzU3ZTQ3OThhNzM3Mjk0MzYxYTQwZThkYzIxZjcyODNiOGZlNTcwZWI2M2MzZDQ4NTI4NDJkNzI5NjgwNTVkYmInO2ouZGF0YXNldC5zdW1vUGxhdGZvcm09J3dvcmRwcmVzcyc7di5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLHYpfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCcvL2xvYWQuc3Vtby5jb20vJyk7" async></script> <script data-phast-original-type="application/javascript" type="text/phast" data-rocketlazyloadscript="data:text/javascript;base64,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"></script>

<script data-phast-original-type="text/javascript" type="text/phast">(function(){function loadHorizon(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src='https://s2982.pcdn.co/wp-content/themes/bookriot/assets/js/vendor/horizon_v1.js';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}
loadHorizon();var oldOnLoad=window.onload;window.onload=function(){if(typeof oldOnLoad==='function'){oldOnLoad();}
Sailthru.setup({domain:'horizon.bookriot.com'});};})();</script>
<script data-phast-original-type="text/javascript" type="text/phast">"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();</script>
<script data-phast-original-type="text/javascript" type="text/phast">(function(){"use strict";var e=function(){function n(e,t){for(var r=0;r<t.length;r++){var n=t[r];n.enumerable=n.enumerable||!1,n.configurable=!0,"value"in n&&(n.writable=!0),Object.defineProperty(e,n.key,n)}}return function(e,t,r){return t&&n(e.prototype,t),r&&n(e,r),e}}();function n(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function r(e,t){n(this,r),this.attrName="data-rocketlazyloadscript",this.browser=t,this.options=this.browser.options,this.triggerEvents=e,this.userEventListener=this.triggerListener.bind(this)}return e(r,[{key:"init",value:function(){this._addEventListener(this)}},{key:"reset",value:function(){this._removeEventListener(this)}},{key:"_addEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.addEventListener(e,t.userEventListener,t.options)})}},{key:"_removeEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.removeEventListener(e,t.userEventListener,t.options)})}},{key:"_loadScriptSrc",value:function(){var r=this,e=document.querySelectorAll("script["+this.attrName+"]");0!==e.length&&Array.prototype.slice.call(e).forEach(function(e){var t=e.getAttribute(r.attrName);e.setAttribute("src",t),e.removeAttribute(r.attrName)}),this.reset()}},{key:"triggerListener",value:function(){this._loadScriptSrc(),this._removeEventListener(this)}}],[{key:"run",value:function(){RocketBrowserCompatibilityChecker&&new r(["keydown","mouseover","touchmove","touchstart"],new RocketBrowserCompatibilityChecker({passive:!0})).init()}}]),r}();t.run();}());</script>
<script data-phast-original-type="text/javascript" type="text/phast">var RocketPreloadLinksConfig={"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/bookriot.com","onHoverDelay":"100","rateThrottle":"3"};</script>
<script data-phast-original-type="text/javascript" type="text/phast">(function(){"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();}());</script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://www.youtube.com/iframe_api"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://s2982.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.4.3"></script>
<script data-phast-original-type="text/javascript" type="text/phast" src="https://stats.wp.com/e-202113.js" async="async" defer="defer"></script>
<script data-phast-original-type="text/javascript" type="text/phast">_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:9.1',blog:'136311887',post:'463121',tz:'-4',srv:'bookriot.com'}]);_stq.push(['clickTrackerInit','136311887','463121']);</script>
<script data-phast-original-type="text/javascript" type="text/phast">dataLayer=dataLayer||[];dataLayer.push({'event':'AuthorPageView'});</script>
<script type="text/phast">window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script type="text/phast" data-no-minify="1" async src="https://s2982.pcdn.co/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<noscript><link rel="stylesheet" href="https://s2982.pcdn.co/wp-content/cache/min/1/81ca555db429f0278259b3a21fd47aef.css" media="all" data-minify="1" /><link rel='stylesheet' id='ohayou-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif&#038;display=swap&#038;ver=5.4.3' type='text/css' media='all' /></noscript><script data-phast-compiled-js-names="ScriptsProxyService/rewrite-function.js,ScriptsDeferring/scripts-loader.js,ScriptsDeferring/rewrite.js">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</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"1fa3ed442f","applicationID":"206885983","transactionName":"Yl0AMUcEX0YAAExRWVsXIwZBDF5bThBRVlFZXQ==","queueTime":0,"applicationTime":236,"atts":"ThoDRw8eTEg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>
<!-- [Phast] Document optimized in 12ms -->

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->